Support / Installation files

STEM 7.2d

06 May 2011

Maintenance release

STEM 7.2d is fully compatible with models created in earlier 7.2 releases and includes the following updates.

ID Description
#2372
Rubbish in the legend of charts when results are produced in opaque mode

Issue: STEM will calculate allocated cost results for services, broken down by individual resource, if you set Cost Breakdown = Opaque or Transparent in the global Other Details dialog. So-called secondary services can be used to group and optionally mask all costs from a 'lower' tier. In order to see what costs are allocated to a primary service from a secondary service, the latter can be selected when drawing a service allocated cost chart, so long as you select the 2D option. While the correct data is graphed, the legend labels could go wrong if more than one such secondary service were selected on the same chart.

Action: The (rather involved) logic has been corrected.

#2431
Cost-allocation circularity issue with Time Lag transformation

Issue: A Time Lag transformation could be used, in principle, to avoid a demand circularity (e.g., where the existing installation of a resource must influence the subsequent demand for that resource for some reason), but delaying the demand is not enough to remove the corresponding circularity when it comes to cost allocation. A separate cost-allocation input for a time-lag transformation was specifically added (April 1996) to solve this kind of problem, but was previously undocumented due to the tentative nature of the addition.

Action: The extra input is finally revealed, now that it has been tested properly and the relevant user-interface actions tided up (especially with regard to drag-and drop).

#3090
Results program hangs on Vista or W7 drawing chart with complex legend

Issue: Recent trainees will have seen the results program lock-up in exercise 9 of the WiMAX-DSL training course at the point where you are asked to graph NPV for multiple scenarios (each of which has a rather long name).

Action: A subtle flaw in the text-layout code for the legend (only exposed on Vista or Windows 7) has now been fixed.

#2929
Scale for difference chart not saved in workspace

Issue: The maximum value on the x-axis for a horizontal bar chart or tornado chart was not restored correctly from a results workspace file if the maximum had been set manually to differ from the automatic value.

Action: The code has been fixed to set the type of chart first (which resets the axes) before restoring the axis values.

#2934
Squared-line chart goes awry if a chart only has one category

Issue: The squared-line chart format ('a line chart which does not interpolate') was originally coded on the assumption that there would always be at least two periods on a chart. However, if the run period data for a working-model chart is unavailable after results are updated (e.g., after running selected scenarios without the working model), then a single emergency period is used to show the #N/A values. As an alert user spotted, this had bizarre consequences for any squared-line format charts.

Action: The squared-line chart format is now coded more defensively: such a chart will simply go blank temporarily in the obscure scenario outlined above!

#2937
User-data results definitions for all standard element types

Issue: Derived results were pre-defined in DEFAULT.CNF for the first ten user-data fields for resources, services and transformation, but not for the simpler elements like locations, market segments and cost indices.

Action: User 1 - User 10 are now pre-defined for all standard elements. It remains an exercise for the user to add further definitions for subsequent user data if these are ever required in practice.

#3061
Crash when copy two interpolated series for function mappings

Issue: An exception could occur in the Mappings dialog (blue link from a service) for a function with two resources if you were to select and copy the two time-series buttons and then attempt to paste this data into an equivalent dialog for another function.

Action: The required interface re-generation is now deferred until the paste operation is completed for all fields in the target selection.

#3066
Long view name truncated in results caption

Issue: The results program main-window caption shows the names of the workspace, configuration, loaded results sets, and the current view; but all current versions of Windows limit the complete text to 160 characters. The current view name would not be displayed at all if adding it would exceed this limit.

Action: The view name is now trimmed to fit with a trailing ellipsis if it would be otherwise too long.

#3067
External database S-curve exception

Issue: Linking defaults for a STEM element from an Access database could generate a memory exception if the external query included a time-series defined as an S-curve. A few current atttributes were also missing from the sample Access database which is supplied with STEM (to demonstrate this functionality).

Action: The code has been fixed and the missing attributes re-instated.

#3069
Scroll bug with laptop track-pad

Issue: Using the scoll action on a laptop track-pad would scroll the main view window in the Editor, even if an icon menu were displayed.

Action: This appears to be a bug in the track-pad design, but a simple code amendment has been made to ignore the spurious scroll messages.

#3077
No clear way to determine if a dependent of a field varied by template varies too...

Issue: An element referred to by a template parameter will be implicitly replicated, but this is not reflected in the associated colour block unless the element is added to the template as an explicit replicant.

Action: The colour block now includes all implicit replicants too.

#3089
Exporting globals to Excel seems to reset the pre-run installation flag to No....

Issue: The global pre-run installation flag was by accident not included in the export at all, which is why it would revert to the default value when 'linked back' from Excel.

Action: The flag is now exported and everything works as expected.

#3137
Normal click to de-select the only selected sensitivity

Issue: Once you have selected a single sensitivity to run (from the Editor) or draw (in the results), it is not immediately obvious that you can use the standard Windows <Ctrl+click> combination if you subsequently want to de-select that sensitivity.

Action: We have added a non-standard but helpful special case condition to allow a normal single click to de-select the last selected sensitivity in either context.

#3150
Results charts messed up after adding an element to a template

Issue: The set of elements presented on a chart appear to randomly change after an element was added to a template.

Action: Prolonged investigation revealed a flaw in the way a results workspace tracks changes to the structure of a model, and this has now been remedied. The results program may now prompt you to save a results workspace file, even if you have not changed any charts, simply to preserve its updated awareness of structural changes in the Editor such as new or renamed elements.

#3151
Update master WiMAX-DSL .SMW file

Issue: Exporting results to Excel could fail for one or two charts where the element names in the workspace file were out of date (as per #3150).

Action: The master workspace file for the WiMAX-DSL model pre-installed with STEM has been corrected. Note: one minor error persists in that the case of a name in a results workspace will not be updated if it is changed only in case in the Editor; e.g., "My Service" to "My service". This manifests as (a) the wrong case shown on charts, and (b) results export failing for this element. The logic will be fixed and tested prior to the next release.

STEM 7.2c

The following issues were addressed in the earlier STEM 7.2c maintenance release, 31 January 2011.

Please note that STEM version 7.2c was the first Implied Logic branded issue of the software. This was an unprecedented mandatory update for all current soft-licence users as the legacy soft-licensing server at Analysys Mason was switched off at the end of March 2011.

ID Description
#2765
Various refinements for results export to Excel

Issue: If you asked the export to insert toolbar definitions, it would unnecessarily (and confusingly) prompt as to whether these should be created in a new sheet.

Action: It now assumes (without prompting) that the toolbar definitions should go in a new sheet. It also copies the current config (.CNF) name into the StemConfigRelativeFilename cell of the toolbar definitions sheet.

#2782
Results export with consolidation

Issue: The original export of results to Excel would always show results in quarters and months, even if they were consolidated to annual values in the Results Program.

Action: The optional ConsolidationMode parameter is now included in the exported StemGetResult() formulae, and a new toolbar definitions sheet will have its StemConsolidationMode cell set to match the option currently selected in the Results Program.

#2880
Installer should mention STEM program group on the Start menu

Issue: A few users were uncertain how to run STEM after completing the installation.

Action: The final screen of the installation wizard now mentions that a STEM program group has been placed on the Start menu.

#2912
Sum over all scenarios

Issue: A client had an unusual requirement to calculate results summed over all the scenarios defined in a model.

Action: The StemGetResult() function for Excel now sums over all scenarios if you enter "*" as the scenario parameter.

This special value should be used with extreme care, as it depends on all scenarios being up to date to work correctly. Please contact support for advice if you think you might need it but are unsure of the interpretation.

#2913
‘Updating n’ message should never go negative!

Action: A benign error in the user-interface status reporting for updating multiple formulae or external links has been fixed.

#2916
WebEx sends Unrecognised STEM app message 0 to results program

Issue: The Results Program would report this (harmless) message multiple times on start-up if the WebEx desktop-sharing client was also running.

Action: The message filter within the Results Program has been refined to ignore this class of external message. In addition, it appears that a new WebEx update pushed out in January 2011 no longer uses the message which caused the problem.

#2917
Re-brand after transition to Implied Logic

Action: The STEM 7.2c software is branded as Implied Logic; notably the about box, Contact Implied Logic dialog, application title bars and error message captions.

#2927
Results periods messed up when working model out of date

Issue: The period labels shown on a graph for the working model could adopt random values after changing an assumption in the Editor and then re-running scenarios without the working model (leaving the working model results out of date).

Action: The run period data for the working model is still inaccessible in such a case, but the period labels for such a chart are now suppressed altogether.

#2928
Clearer message for unit-label incompatibility in results

Issue: If you draw a graph of, e.g., Demand in Connections for two services whose connections units differ, then STEM will report an error and display neither unit label on the graph. However, the original error message was hard to read because it reported too much information and did not delimit the element names clearly.

Action: The model name(s) are no longer included in the message (more often than not it will be the same model), and the element names are now quoted.

#2930
Remove results workspace merge message!

Issue: When you run a new model through to the results program, after previously viewing the results of another model, STEM would prompt whether to close the previous results first. (The alternative was to load both sets of results together in the same workspace.)

From repeated observation, it was clear that most users did not understand the text of the prompt (already our second draft), and that 99% of the time the correct answer would be Yes (i.e., to close the previous results).

Action: STEM 7.2c no longer prompts when you run a model through from the Editor; the previous results are closed and you are given the option to save (or cancel) if the previous workspace has changed. If you really want to open two sets of results together, then the Results Program will still prompt if you manually select Open Results from the File menu.

#2931
Option to suppress model name from chart minor titles

Issue: The minor title of a chart in the Results Program shows all the common dimensions of the lines on the chart. The model name was always included, with the option to show the full path; whereas it became obvious from observation that the vast majority of charts compare results (or at worst) scenarios all from within the same model.

Action: STEM 7.2c provides an option to suppress the model name altogether, which is the default setting for new charts. This option (like the full path option) can be changed on a per chart basis from the Format menu, or for all charts by selecting Graph Format... from the Options menu.

#2933
Implied Logic brand and update settings for the installer

Action: The STEM 7.2c installer is branded as Implied Logic.

#2936
Soft-licensing from Implied Logic

Issue: STEM 7.2b and all earlier versions of STEM rely on Analysys Mason’s goodwill in maintaining a legacy soft-licensing server. It has been a fundamental priority to remove this dependence at the earliest opportunity.

Action: STEM 7.2c requests soft licences from Implied Logic’s own servers. This is quickly evident in that new licence-key emails are received from Implied Logic Support.

Advice: Although we cannot expect all users to change overnight, we have made this a mandatory update for all current soft-licence users as the legacy soft-licensing server at Analysys Mason will be switched off at the end of March. This means that it will not be possible to refresh a soft licence for any earlier version of STEM after 31 March 2011. Although this cut-off date is rather arbitrary, we have had to draw a ‘line in the sand’ to ensure that this mission-critical system will shortly become firmly under our sole control and repair.

STEM 7.2b

The following issues were addressed in the earlier STEM 7.2b maintenance release, 29 April 2010.

ID Description
#2895
Excel 2007 compatibility

Issue: There are a number of issues with Office 2007, which we have been working through since training a new client late last year who is running Windows 7 + Office 2007. We have already made some urgent updates to our training guide.

  • The first gotcha is that STEM cannot yet read the Excel 2007 format.* So a new workbook should be saved in Excel 97-2003 format before attempting to link inputs into STEM.
  • When you use the Export Model Data command, if the export workbook did not previously exist, then Excel 2007 will create this in Excel 2007 format, even though we have specified the .xls extension; and will then complain that the format does not match the extension when it tries to open the file.** So you need to ignore the message about the non-matching extension, and then (very important) save in Excel 97-2003 format before saying Yes to the prompt from STEM to continue to modify the STEM model to refer to the newly exported data in Excel.
  • If you are using Excel 2007, the Add-Ins command is accessed via the Microsoft Office Button and Excel Options.
  • If you are using Excel 2007, the toolbar will only be visible when you select the Add-Ins menu (or 'tab' of the 'ribbon', as it is now known).
  • Depending on your company templates, it may be necessary to change the Excel 2007 macro security setting for a new workbook to allow access to its internal 'VB project module' to enable the STEM add-in to work properly. You can access the relevant settings in Excel via the Excel Options dialog box. Click the Microsoft Office Button and then click Excel Options. In the Trust Center category, click Trust Center Settings, and then click the Macro Settings category. You need to tick 'Trust access to the VBA project object model'.

Action: ** Now fixed: the STEM export model data function now ensures that Excel saves a new workbook in Excel 97-2003 format.

Advice: There is one further issue which we are not yet 100% clear on, which is that we have seen Excel 2007 _remove_ the VB reference to STEM.XLA from a workbook which was previously working. You can tell this has happened if StemGetResult() comes back with #NAME?. The empirical solution is as follows:

  1. In the toolbar definitions sheet in Excel, set Add VB Reference = TRUE
  2. Click the first button of the STEM toolbar. This should indirectly lead to the reference being re-instated, and you should then see Add VB Reference = ADDED.
  3. You may need to close and re-open the workbook at some stage.

* We will address this in future, but it is not straightforward. Reading the .xlsx format natively (as we do for .xls) would be a major development effort, and the easy alternative (reading it via the Excel application server) would be hideously slow in comparison.

#2902
Connect mode crashes on toolbar in new model

Issue: Connect mode could crash in a new model with no elements if you clicked on the toolbar.

Action: Fixed in STEM 7.2b.

#2903
Editor crashes after connect transformation to a resource

Issue: The Editor would crash if you tried to connect a transformation and resource which both had very long names.

Action: Fixed in STEM 7.2b.

#2904
Increase the number of scenario and template parameters to 240

Issue: In very large template models, it was possible to 'run out' of parameters.

Action: An extra 120 parameters have been added for scenario and template variants.

#2906
Debt Facility Start Date handled incorrectly if not specified as a relative date

Issue: The Start Date for a Debt Facility was handled correctly if specified as a relative date, such as Y3, but not if you specified it as a calendar year, such as 2003.

Action: Fixed in STEM 7.2b.

#2911
Toolbar definitions sheet not named

Issue: The Export Model Data command names new sheets as Inputs 1, 2, ..., and the Export Results to Excel command names new sheets as Results 1, 2, ...; whereas a newly created Toolbar definitions sheet was just left as Sheet 1, 2, 3 ...

Action: The add-in now names the STEM control sheet as "Toolbar definitions".

STEM 7.2a

The following issues were addressed in the earlier STEM 7.2a maintenance release, 27 January 2010.

ID

Description
#2373
Add-in flag to suppress StemGetResult() status info

Issue: A customer wished to populate a table of service allocated-cost results for service / resource pairs where not all pairs generate results (because they may be unrelated in the model). However, they preferred not to see the error message, 'Element not found', in this case.

Action: We have added a 'Suppress Errors' flag to the Stem Toolbar Definitions sheet. When this is set to FALSE (the default), the STEM add-in reports errors as usual. However, if it is set to TRUE, then the StemGetResult() function returns an array of empty variants (instead of an error message) from which Excel will set a zero value into each affected cell.

#2881
STEM 7.2 doesn't recognise my dongle

Issue: The original STEM 7.2 build did not correctly recognise a STEM 7.2 hardware dongle.

Action: Fixed in STEM 7.2a.

#2884
How to distinguish between replacement capex and new capex

Issue: A customer wished to differentiate between initial capex and replacement capex in a modelling context where some equipment installed early on was being replaced before the project was complete.

Action: STEM 7.2a introduces a new Expired Units result, from which a Replacement Proportion is inferred for Incremental Units, and which is then used to split capital expenditure and associated depreciation between initial and replacement equipment.

#2886
Error running a model from Excel

Issue: Attempting to run a model from Excel would result in the message, "Variable not defined - pcMsgTitle."

Action: Fixed in STEM 7.2a.

#2889
2D Selection checkbox not moved when dialog resized

Issue: If you draw a graph for a service allocated-cost result, then the initial choose elements to draw dialog (for services) includes a 2D Selection checkbox which controls how the secondary selection of resources is presented. This checkbox was not being moved with the other controls if the dialog was resized.

Action: Fixed in STEM 7.2a.

Download
STEM 7.2d installer

Registered licensees with a current maintenance contract can download the appropriate C-STEM or D-STEM 7.2d installer.

Download now: C-STEM 7.2D-STEM 7.2

       Buy SSL

© Implied Logic Limited